Jumat, 23 September 2016

Panduan Servis Kawasaki Ninja RR Mono, Lebih Cepat Lebih Baik

Berhubung gw punya motor ini, jadi gw harus simpen bacaan ini, suatu saat pasti butuh.buat kalian yang mungkin ingin mengetahui lebih lanjut perewatan pertama motor baru silahkan untuk disimak berita ini
sumber yang didapat dari otomotifnet.com

Jakarta - Lahir sebagai pengganti Kawasaki Ninja 150-2 tak, kehadirannya cukup diterima penyuka kecepatan. Dengan mesin 250 cc bersilinder tunggal yang kaya torsi, didukung pula dengan bobot yang ringan membuat Kawasaki Ninja RR Mono cukup disegani. Tapi kali ini bukan mau bicara banyak soal performanya, justru akan ulas servis  Kawasaki Ninja RR Mono atau perawatan berkala motor full fairing ini.
Dalam buku panduan servis Kawasaki Ninja RR Mono yang dirilis PT Kawasaki Motor Indonesia (KMI), pada 1.000 km pertama harus langsung ganti oli untuk membuang kotoran logam di mesin sisa proses produksi. Kemudian, servisakan dilakukan pada 6.000 km, 12.000 km dan seterusnya tiap kelipatan 6.000 km. Check list-nya bisa dilihat di tabel.
Sedang penggantian oli wajib dilakukan tiap 12.000 km bersamaan dengan penggantian filter oli. Spesifikasi pelumasnya adalah 10W- 40 dengan jumlah 1 liter jika filter oli tidak dilepas, 1,1 liter jika dibarengi penggantian filter oli dan 1,3 liter jika mesin dibongkar. Oiya jangan lupa juga untuk mengganti gasket baut penguras oli dengan yang baru untuk mencegah kebocoran.
Yang harus dicek dan diganti secara berkala adalah busi dan selang rem juga komponen karet di master rem dan kaliper tiap 48.000 km. Sedangkan radiator coolant, selang pendingin dan o-ring wajib ganti tiap 36.000 km. Meski interval perawatan dan penggantian komponen fast moving cukup lama, namun yang ingin melakukan servis lebih cepat tidak ada pantangan.
Oli misalnya, Eddy Yulianto kepala mekanik di Kawasaki Super Sukses Motor justru menyarankan penggantian lebih cepat. “Kalau masih memakai oli standar KGO Ultimate pemakaian maksimal 1.500 km, namun kalau sudah pakai Vent Vert berani deh menjamin pemakaian sampai kelipatan 3.000-4.000 km,” bukanya.
Selanjutnya urusan busi misalnya, pemantik iridium berkode NGK MR8CI-8 ini sebaiknya selalu dicek celahnya selalu berada pada 0,8 mm. “Tiap 12.000 km sebaiknya ganti, jangan terlalu lama,” beber Edoy sapaan karibnya. Pria yang bengkelnya ada di Jl. RS Fatmawati Raya, Jaksel ini juga membeberkan kerap terjadi kerusakan pada kipas radiator. “Sudah ada beberapa yang mengalami masalah ini, kipas radiator lemah sehingga mesin jadi cepat panas dan overheat.
Kalau sudah seperti ini harus ganti,” paparnya. Pria kelahiran Jakarta ini juga menyarankan untuk melakukan kuras radiator tiap 6 bulan, lebih cepat ketimbang saran pabrikan di 36.000 km. Tentunya agar mesin berkompresi 11,3 : 1 ini tetap adem, karena kalau sampai overheat ada dua akibat fatal yang bisa terjadi. Pertama, kerusakan di bagian silinder, kruk as dan piston. Kedua adalah penguapan oli karena temperatur mesin yang terlalu panas. Jadi, lebih cepat lebih baik deh! • (otomotifnet.com)
Check List Pemeriksaan
Pemeriksaan sistem kontrol throttle
Sinkronisasi vacum mesin
Putaran stasioner
Periksa sistem bahan bakar
Periksa sistem pendingin
Permeriksaan emisi gas buang
Pemeriksaan DFI (Digital Fuel Injection)
Pemeriksaan jarak bebas selongsong gas
Fungi kerja kopling
Periksa kekenduran & pelumasan rantai
Periksa keausan rantai penggerak
Periksa tekanan udara ban
Periksa keausan ban
Periksa kerusakan bearing roda
Periksa fungsi kerja rem
Pemeriksaan switch lampu dan arah sorot
lampu
Pengecekan batas ketinggian minyak rem
Periksa gerakan dan kebocoran oli suspensi
Periksa gerakan kemudi
Periksa mur baut dan pengencang
Daftar Harga
Jasa servis ringan Rp 130.000
Jasa servis besar Rp 175.000
Jasa kuras radiator Rp 40.000
Oli KGO Ultimate Rp 45.000
Oli Vent Vert Rp 80.000
Filter oli Rp 13.000
Kipas radiator Rp 324.000
Filter udara Rp 44.000
Busi Rp 155.000
Air radiator Rp 35.000
Kampas rem d/b Rp 212 .000

Senin, 25 Juli 2016

VNC and Raspberry Pi

VNC and Raspberry Pi

VNC is now available for the Raspberry Pi:
  • Professional-class software from the original inventors of VNC.
  • VNC Server can run in different modes, for remote access in different circumstances.
  • Free VNC Viewer apps to connect in from virtually any device.
  • Enable the feature set that suits you best by applying a Free, Personal, or Enterprise license to VNC Server on your Pi.
All the commands in this article can be run over SSH if you’re setting up VNC remotely, unless otherwise stated.

Downloading, installing, and licensing VNC

  1. On your Pi, either download the VNC DEB package, or run the following commands:
    curl -L -o VNC.tar.gz https://www.realvnc.com/download/binary/latest/debian/arm/
    tar xvf VNC.tar.gz
  2. Install VNC Server (installing VNC Viewer as well means you can remotely access computers from your Pi, if you wish):
    sudo dpkg -i .deb [.deb]
  3. Apply a license key to VNC Server (typically received via email):
    sudo vnclicense -add

Getting connected

We recommend the following modes for VNC Server on the Pi:
Service Mode Virtual Mode
_images/raspberry-pi-service.png
VNC Server remotes your graphical desktop on the Pi. Connected VNC Viewer users see exactly what a person sitting in front of the Pi would see.
_images/raspberry-pi-virtual.png
VNC Server creates and remotes a virtual desktop. Connected VNC Viewer users therefore do not see what a person sitting in front of the Pi would see. Instead, they gain access to a persistent private workspace.
Set a password before you start VNC Server the first time. With a Free license, you must create a new VNC password:
sudo vncpasswd -service
With a Personal or Enterprise license, there’s nothing to do. Your pi username and password will work out-of-the-box.
There’s nothing to do here.
With a Free license, you’ll be prompted to create a new VNC password when you start VNC Server the first time (see below).
With a Personal or Enterprise license, your pi username and password will work out-of-the-box.
Start VNC Server:
# Debian 8 Jessie
sudo systemctl start vncserver-x11-serviced.service
# Debian 7 Wheezy
sudo /etc/init.d/vncserver-x11-serviced start
It may be more convenient to start VNC Server automatically when your power the Pi on:
# Debian 8 Jessie
sudo systemctl enable vncserver-x11-serviced.service
# Debian 7 Wheezy
sudo update-rc.d vncserver-x11-serviced defaults
Note VNC Viewer users won’t be able to connect in until you start your graphical desktop using startx. You can’t run this command over SSH, so the easiest thing to do is use raspi-config to Enable Boot to Desktop automatically.
Start VNC Server:
vncserver
Note you don’t (ever) have to start your graphical desktop using startx; VNC Server immediately creates the virtual desktop in memory and makes it available to VNC Viewer on the first available display, for example :1. This means you can run the Pi headless but still have visual access over VNC.
With a Free license, you can start VNC Server up to five times to create five separate virtual desktops. With a Personal or Enterprise license, you can start VNC Server as many times as your license permits.
To connect in over a local network, enter the private IP address of your Pi into VNC Viewer. You can find this out by running ifconfig, or from the VNC Server dialog:
_images/raspberry-pi-service-address.png
Note if your Pi is headless and the screen you see is too small, you can force a more convenient resolution.
To connect in over a local network, enter the private IP address and display number into VNC Viewer. VNC Server prints this information to the console when you start it:
_images/raspberry-pi-virtual-address.png
To connect in over the Internet, you must first configure any firewalls to enable VNC Server, port forward your router to the private IP address of the Pi, and enter the public IP address into VNC Viewer. More information.
To stop VNC Server in Service Mode:
# Debian 8 Jessie
sudo systemctl stop vncserver-x11-serviced.service
# Debian 7 Wheezy
sudo /etc/init.d/vncserver-x11-serviced stop

Rabu, 15 Juni 2016

AP Provisioning Controller

AP Provisioning


The first thing we should know about Aruba Access Points its that they can work in different modes(depending on how you buy it)
  1. If you buy an Aruba Instant AP it can work as a stand alone AP or a controllerless solution which does not need a physical controller
  2. If you buy normal APs which are not Aruba Instant then the APS are thin APS and ahts what we are going to talk here.

What are thin APs?
Its an AP that contains a minimal configuration, most of the config is located on the controller.

To boot correctly the AP need a few things otherwise you wont be able to provision it.   When i say provision i mean configure this thin AP.
Here is the requirements(be sure the AP got them all so it can successfully communicate with the controller)
  1. IP Address, DNS, Defauilt Gateway, network mask
  2. Controllers(IP or DNS Name)

Now how do we get the IP address and the controller address?

You can do it statically by setting it at the APBOOT with a console cable connected directly to the console port of the AP

Here is how you do it:

To set him the ip address:
1.  setenv ipaddr

To set him the network mask
2.  setenv netmask

To set him the Gateway
3.  setenv gatewayip

4.  setenv master 

This command is to set from which controller he wil download the firmare if he needs to download, and also from which controller he will download the configuration
5.  setenv serverip

After doing all this you need to save the config with this command:
6.  saveenv


Now if you donig it dynamically

The process is like this:

  1. DHCP Request(he will get the IP address of the AP by DHCP and also he will try to get the master IP by DHCP if it configured with the option 43
  2. If not he will try to multicast by ADP(aruba Discovery protocol) to find the controller IP
  3. If not he will try to broadcast ADP to find the controller ip address
  4. if not he will try to send  dns query to aruba-master to see if the dns server knows the ip of aruba-master

Example of AP Provisioning went you got the record of aruba-master on the DNS server and you are distributing DHCP on the port that you will connect the AP.

The first thing you need is to create the statically A record on your DNS server
Like this
recordA.JPG

Now with this entry the AP will be able to find the controller with the DNS
For example when you connect a AP to the network and the DHCP server send him the ip address, netmask, default gateway and DNS Server,  he will ask the DNS server who is aruba-master and in this case the DNS will asnwer its 172.16.3.216


Go to the controllerand check the control plane security settings
A really easy way is that when you are provisioning just put autocert provisioning(just when you are provisioning)

control plane security.JPG

after you done provisioning please uncheck the auto cert provisioning(thats just for security purpuse)

Okay now you connect the AP to the network

You will notice that the AP will reboot like twice.   One to download and install the firmware on the AP and the second time to install the certificate.

After that you will see the AP on AP installation tab

approvisioning.JPG


As you see on this example the AP as name will have the mac address of it, and the default group he will be is on the default one

now you just need to provision it

You need to select it and click provisioning like this
approvisioning0.JPG

After you click provision you need just to configure a few things like this
provisioning1.JPG
Select the ap group, select indoor if its an indoor AP

approvisioning2.JPG

After that you just change the name and thats it!

Click Apply and Reboot

Well thats it, it will reboot and it will come up with the configuration

Jumat, 20 Mei 2016

Spanning Tree Protocol (STP) beserta Konfigurasinya

Dalam membangun suatu infrastruktur jaringan, kita membangun pondasi infrastruktur logis (seperti layanan directory dari system windows server 2003, domain name system) dan juga infrastruktur fisik (seperti domain controller, piranti jaringan seperti router dan switch). Switch adalah piranti jaringan yang paling banyak dipakai dalam suatu infrastruktur jaringan fisik.Sebagaimana yang telah kita ketahui bahwa switch dibuat berdasarkan konsep bridge.
Bridge merupakan piranti murni yang bekerja pada layer Data Link pada model OSI, dimana merupakan cikal bakal daripada Switch LAN.
Ada tiga jenis bridge:
  1. Transparant bridge (untuk jaringan Ethernet dan Token Ring)
  2. Source-routing bridge (untuk jaringan Token Ring saja)
  3. Source-routing transparent bridge (untuk jaringan Token Ring saja)
Karena kita hanya membahas jaringan Ethernet saja, maka hanya jenis transparent bridge saja yang kita akan bahas. Suatu bridge disebut transparent jika kedua piranti pengirim dan penerima dalam suatu komunikasi dua piranti tidak menyadari adanya suatu bridge. Yang mereka tahu hanya lah bahwa keduanya berada pada segmen yang sama.
Bagaimana transparent bridge bekerja?
  • Transparent bridges membangun database mengenai data dari piranti dan disegmen mana piranti tersebut berada dengan cara memeriksa sumber address dari paket yang datang. Untuk bridge yang baru dipasang database masih kosong. Begitu juga piranti jaringan yang baru dikoneksikan ke bridge tidak ada dalam database.
  • Transparent bridge meneruskan paket berdasarkan aturan berikut:
  1. Jika address tujuan tidak diketahui (tidak ada didatabase ), maka bridge meneruskan paket kesemua segmen.
  2. Jika address tujuan diketahui dan ada di segmen yang sama, maka bridge membuang paket tersebut, jadi tidak dilewatkan ke segmen lainnya.
  3. Jika address tujuan diketahui dan berada di segmen lain, maka bridge meneruskan paket kepada segmen yang tepat.
  • Transparent bridge meneruskan paket hanya jika kondisi berikut dipenuhi:
  1. Frame berisi data pada layer bagian atas (data dari sub-layer LLC keatas)
  2. Integritas frame telah diverifikasi (suatu CRC yang valid)
  3. Frame tersebut tidak dialamatkan kepada bridge
Bridging loops dan STA – Algoritma Spanning Tree
Bridge menghubungkan dua segmen LAN, membentuk satu jaringan. Bridge, dengan namanya saja sudah mensiratkan arti sebuah jembatan, merupakan titik pertemuan antara dua segmen jaringan.
Jika bridge ini tidak berfungsi, maka sudah pasti traffic antara kedua segmen jaringan tersebut menjadi tidak mungkin. Agar dua jaringan tadi bisa fault tolerance (artinya jika ada kerusakan maka harus ada backup yang menggantikan fungsi tersebut), maka setidaknya harus ada dua bridge untuk menghubungkan kedua jaringan.
Spanning Tree Protocol - Bridging Loop
Spanning Tree Protocol - Bridging Loop
Pada gambar ini, kedua jaringan dihubungkan dua buah bridge yang bersifat fault tolerance, jika fungsi bridge yang beroperasi tidak berfungsi, atau gagal berfungsi, maka bridge satunya akan menggantikan fungsi bridge yang gagal fungsi tadi. Walaupun kedua bridge ini hidup, akan tetapi secara teori hanya satu saja yang berfungsi (misalnya bridge #1). Jika bridge # 1 ini tidak berfungsi, maka bridge # 2 akan menggantikan fungsinya.
broadcast storm
Spanning-Tree Protocol - broadcast storm
Spanning Tree Protocol – Broadcast Storm
Kenapa hanya satu? Jika keduanya berfungsi, maka terjadi redundansi link (jalur) antara dua segmen jaringan tersebut. akibatnya sudah dipastikan bahwa paket antar dua jaringan tersebut berputar-putar melewati kedua bridge tadi tanpa henti sampai akhirnya mati sendiri. Kondisi ini disebut sebagai bridging loops atau bisa juga disebut dengan broadcast storm.
Untuk mencegah terjadinya bridging loop, komisi standard 802.1d mendifinisikan standard yang disebut Spanning Tree Algoritm (STA), atau Spanning Tree Protocol (STP). Dengan protocol ini, satu bridge untuk setiap jalur (rute) di beri tugas sebagai designated bridge. Hanya designated bridge yang bisa meneruskan paket. Sementara redundansi bridge bertindak sebagai backup.
Keuntungan dari spanning tree algoritma
Spanning tree algoritma sangat penting dalam implementasi bridge pada jaringan. Keuntungan nya adalah sebagai berikut:
  • Mengeliminir bridging loops
  • Memberikan jalur redundansi antara dua piranti
  • Recovery secara automatis dari suatu perubahan topology atau kegagalan bridge
  • Mengidentifikasikan jalur optimal antara dua piranti jaringan
Baaimana spanning tree bekerja?
Spanning tree algoritma secara automatis menemukan topology jaringan, dan membentuk suatu jalur tunggal yang yang optimal melalui suatu bridge jaringan dengan menugasi fungsi-2 berikut pada setiap bridge. Fungsi bridge menentukan bagaimana bridge berfungsi dalam hubungannya dengan bridge lainnya, dan apakah bridge meneruskan traffic ke jaringan-2 lainnya atau tidak.

Spanning Tree Protocol – Root Bridge
1. Root bridge
Root bridge merupakan master bridge atau controlling bridge. Root bridge secara periodik mem-broadcast message konfigurasi. Message ini digunakan untuk memilih rute dan re-konfigure fungsi-2 dari bridge-2 lainnya bila perlu. Hanya ada satu root bridge per jaringan. Root bridge dipilih oleh administrator. Saat menentukan root bridge, pilih root bridge yang paling dekat dengan pusat jaringan secara fisik.
2. Designated bridge
Suatu designated bridge adalah bridge-2 lain yang berpartisipasi dalam meneruskan paket melalui jaringan. Mereka dipilih secara automatis dengan cara saling tukar paket konfigurasi bridge. Untuk mencegah terjadinya bridging loop, hanya ada satu designated bridge per segment jaringan
3. Backup bridge
Semua bridge redundansi dianggap sebagai backup bridge. Backup bridge mendengar traffic jaringan dan membangun database bridge. Akan tetapi mereka tidak meneruska paket. Backup bridge ini akan mengambil alih fungsi jika suatu root bridge atau designated bridge tidak berfungsi.
Bridge mengirimkan paket khusus yang disebut Bridge Protocol Data Units (BPDU) keluar dari setiap port. BPDU ini dikirim dan diterima dari bridge lainnya digunakan untuk menentukan fungsi-2 bridge, melakukan verifikasi kalau bridge disekitarnya masih berfungsi, dan recovery jika terjadi perubahan topology jaringan.
Perencanaan jaringan dengan bridge mengguanakan spanning tree protocol memerlukan perencanaan yang hati-2. Suatu konfigurasi yang optimal menuntut pada aturan-2 berikut ini:
  • Setiap bridge sharusnya mempunyai backup (yaitu jalur redundansi antara setiap segmen)
  • Packet-2 harus tidak boleh melewati lebih dari dua bridge antara segmen-2 jaringan
  • Packet-2 seharusnya tidak melewati lebih dari tiga bridge setelah terjadi perubahan topology.
Spanning tree protocol (STP) adalah layanan yang memungkinkan LAN switches dikoneksikan secara redundansi dengan memberikan suatu mekanisme untuk mencegah terjadinya suatu bridging loops.
Kebutuhan minimum yang berhubungan dengan STP adalah sebagai berikut:
1. Versi standard STP adalah 802.1d dan harus di “enable” pada semua switch (walaupun by default switch adalah “enable” STP nya). STP tidak boleh di “disabled” disemua switches.
2. Dokumentasi jaringan harus ada dan menunjukkan dengan jelas topology jaringannya termasuk redundansi link yang mungkin ada
3. Yang ini sangat direkomendasikan: bahwa port Switch yang dihubungkan ke pada komputer, printer, server, dan router (tetapi tidak ke switch, bridge atau hub) haruslah “STP port-fast enabled”. Port-fast juga sering disbut sebagai fast-start atau start-forwarding. Port-fast dapat digunakan untuk mempercepat transisi port host untuk antisipasi transisi lambat dari berbagai kondisi STP. Tanpa adanya port-fast “enable” kebanyakan koneksi akan mengalami time-out saat melakukan koneksi pertama kali. Telah diketemukan bahwa banyak koneksi Novell IPX dan DHCP mengalami time-out bahkan gagal jika tanpa port-fast “enable”.
Jangan melakukan “enable” STP port-fast pada port koneksi antar switch karena akan menimbulkan bridging loop kepada jaringan. STP port-fast adalah fitur dari kebanyakan Switch yang versi baru (modern) dan biasanya tidak di “enable” by default.
Bentuk topologi STP yang akan dibuat dengan menggunakan Packet Tracer 5.1:
Setelah memahami tujuan dibuatnya VLAN dan ulasan mengenai STP, mari kita coba untuk membuat sebuah topologi yang menggunakan VLAN dan juga STP tentunya. Berikut gambaran topologi yang akan kita buat :
Topologi STP
Topologi STP
Di topologi ini kita akan mengunakan 1 switch sebagai server dan 2 switch sebagai client. Dimana yang bertindak sebagai Server adalah S1(akan dijelaskan konfigurasinya), sedangkan yang bertindak sebagai client adalah S2 dan S3.
Setelah menentukan switch yang bertindak sebagai server ataupun client, langkah berikutnya adalah melakukan konfigurasi VLAN pada switch server S1.
Konfigurasi pada switch S1 yang bertindak sebagai server:
Sebelumnya, ada baiknya kita melihat tabel VLAN yang belum dikonfigurasi :
Switch>
Switch>en
Switch#sh vlan

VLAN  Name                              Status    Ports
---- -------------------------------- ---------   -------------------------------
1    default                           active    Fa0/1, Fa0/2, Fa0/3,  Fa0/4
 Fa0/5, Fa0/6, Fa0/7,  Fa0/8
 Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,   Fa0/20
 Fa0/21,  Fa0/22, Fa0/23,  Fa0/24
1002 fddi-default                     active
1003 token-ring-default               active
1004  fddinet-default                  active
1005 trnet-default                     active   

VLAN Type  SAID       MTU   Parent RingNo  BridgeNo Stp  BrdgMode Trans1  Trans2
---- ----- ---------- -----  ------ ------ -------- ---- -------- ------  ------
1    enet  100001      1500  -      -      -        -    -        0      0
1002 enet   101002     1500  -      -      -        -    -        0      0
1003  enet  101003     1500  -      -      -        -    -        0      0
1004  enet  101004     1500  -      -      -        -    -        0      0
1005  enet  101005     1500  -      -      -        -    -        0      0
Pemberian nama switch sebagai S1 :
Switch#conf t
Enter configuration  commands, one per line.  End with CNTL/Z.
Switch(config)#hostname S1
Konfigurasi S1 sebagai switch server :
S1(config)#vtp mode server
Device  mode already VTP SERVER.
S1(config)#vtp domain zuyan
Changing VTP  domain name from NULL to zuyan
S1(config)#vtp password cisco
Setting  device VLAN database password to cisco
Pembuatan VLAN pada S1:
S1(config)#vlan 2
S1(config-vlan)#name  TI
S1(config-vlan)#exit
S1(config)#vlan 3
S1(config-vlan)#name  SI
S1(config-vlan)#exit
S1(config)#vlan 4
S1(config-vlan)#name  SK
S1(config-vlan)#exit
S1(config)#vlan 5
S1(config-vlan)#name  TKJ
S1(config-vlan)#exit
S1(config)#vlan 6
S1(config-vlan)#name  INHERENT
S1(config-vlan)#exit
S1(config)#^Z
Note : Dalam topologi ini, VLAN 1 bertindak sebagai default VLAN.
Melihat tabel VLAN setelah VLAN dibuat :
S1#sh  vlan

VLAN  Name                              Status    Ports
----  -------------------------------- ---------   -------------------------------
1    default                           active    Fa0/1, Fa0/2, Fa0/3,  Fa0/4
 Fa0/5, Fa0/6, Fa0/7,  Fa0/8
 Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,   Fa0/20
 Fa0/21,  Fa0/22, Fa0/23,  Fa0/24
2    TI                               active
3    SI                               active
4    SK                                active
5    TKJ                               active
6    INHERENT                         active
1002  fddi-default                     active
1003 token-ring-default                active
1004 fddinet-default                  active
1005  trnet-default                    active   

VLAN Type  SAID        MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1  Trans2
---- -----  ---------- ----- ------ ------ -------- ---- -------- ------  ------
1     enet  100001     1500  -      -      -        -    -        0      0
2     enet  100002     1500  -      -      -        -    -        0      0
3     enet  100003     1500  -      -      -        -    -        0      0
4     enet  100004     1500  -      -      -        -    -        0      0
5     enet  100005     1500  -      -      -        -    -        0      0
6     enet  100006     1500  -      -      -        -    -        0      0
1002  enet  101002     1500  -      -      -        -    -        0      0
1003  enet  101003     1500  -      -      -        -    -        0      0
1004  enet  101004     1500  -      -      -        -    -        0      0
1005  enet  101005     1500  -      -      -        -    -        0
Konfigurasi interface fastEthernet0/1 sampai 0/4 sebagai switchport trunk native vlan 1:
S1#
S1#conf t
Enter  configuration commands, one per line.  End with CNTL/Z.
S1(config)#interface  range fa0/1-4
S1(config-if-range)#switchport mode trunk

%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/1, changed  state to down
%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/1, changed  state to up

%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/2, changed  state to down
%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/2, changed  state to up

%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/3, changed  state to down
%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/3, changed  state to up

%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/4, changed  state to down
%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/4, changed  state to up
S1(config-if-range)#switchport  trunk native vlan 1
S1(config-if-range)#^Z
Berikut tabel VLAN-nya :
S1#sh vlan

VLAN Name                              Status    Ports
----  -------------------------------- ---------   -------------------------------
1    default                           active    Fa0/5, Fa0/6, Fa0/7,  Fa0/8
 Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,  Fa0/20
 Fa0/21, Fa0/22, Fa0/23,   Fa0/24
2    TI                               active
3    SI                                active
4    SK                                active
5    TKJ                              active
6     INHERENT                         active
1002 fddi-default                      active
1003 token-ring-default                active
1004 fddinet-default                  active
1005  trnet-default                    active   

VLAN Type  SAID        MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1  Trans2
---- -----  ---------- ----- ------ ------ -------- ---- -------- ------  ------
1     enet  100001     1500  -      -      -        -    -        0      0
2     enet  100002     1500  -      -      -        -    -        0      0
3     enet  100003     1500  -      -      -        -    -        0      0
4     enet  100004     1500  -      -      -        -    -        0      0
5     enet  100005     1500  -      -      -        -    -        0      0
6     enet  100006     1500  -      -      -        -    -        0      0
1002  enet  101002     1500  -      -      -        -    -        0      0
1003  enet  101003     1500  -      -      -        -    -        0      0
1004  enet  101004     1500  -      -      -        -    -        0      0
1005  enet  101005     1500  -      -      -        -    -        0      0
Pembagian VLAN :
S1>en
S1#conf  t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#interface  fa0/5
S1(config-if)#switchport mode access
S1(config-if)#switchport  access vlan 2
S1(config-if)#exit
S1(config)#interface fa0/6
S1(config-if)#switchport  mode access
S1(config-if)#switchport access vlan 3
S1(config-if)#exit
S1(config)#interface  fa0/7
S1(config-if)#switchport mode access
S1(config-if)#switchport  access vlan 4
S1(config-if)#exit
S1(config)#interface fa0/8
S1(config-if)#switchport  mode access
S1(config-if)#switchport access vlan 5
S1(config-if)#exit
S1(config)#interface  fa0/22
S1(config-if)#switchport mode access
S1(config-if)#switchport  access vlan 6
S1(config-if)#^Z
Tabelnya :
S1#sh  vlan

VLAN Name                             Status    Ports
----  -------------------------------- ---------   -------------------------------
1    default                           active    Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,  Fa0/20
 Fa0/21, Fa0/23, Fa0/24
2     TI                               active    Fa0/5
3    SI                                active    Fa0/6
4    SK                                active    Fa0/7
5    TKJ                              active     Fa0/8
6    INHERENT                         active    Fa0/22
1002  fddi-default                      active
1003 token-ring-default               active
1004  fddinet-default                  active
1005 trnet-default                     active   

VLAN Type  SAID       MTU   Parent RingNo  BridgeNo Stp  BrdgMode Trans1  Trans2
---- ----- ---------- -----  ------ ------ -------- ---- -------- ------  ------
1    enet  100001      1500  -      -      -        -    -        0      0
2    enet   100002     1500  -      -      -        -    -        0      0
3     enet  100003     1500  -      -      -        -    -        0      0
4     enet  100004     1500  -      -      -        -    -        0      0
5     enet  100005     1500  -      -      -        -    -        0      0
6     enet  100006     1500  -      -      -        -    -        0      0
1002  enet  101002     1500  -      -      -        -    -        0      0
1003  enet  101003     1500  -      -      -        -    -        0      0
1004  enet  101004     1500  -      -      -        -    -        0      0
1005  enet  101005     1500  -      -      -        -    -        0      0
Konfigurasi pada switch S2 yang bertindak sebagai client:
Pemberian nama switch sebagai S2 :
Switch>
Switch>en
Switch#conf  t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname  S2
Konfigurasi S2 sebagai switch client :
S2(config)#vtp mode client
Setting  device to VTP CLIENT mode.
S2(config)#vtp domain zuyan
Domain name  already set to zuyan.
S2(config)#vtp password cisco
Setting  device VLAN database password to cisco
Pembuatan VLAN pada S2 tidak perlu dilakukan lagi, karena telah dilakukan pada server(S1), hanya saja kita perlu men-set sebagai switchport trunk native vlan 1 pada interface-interface yang berhubungan dengan S1 dan S3 :
S2(config)#interface range fa0/1-4
S2(config-if-range)#switchport  mode trunk
S2(config-if-range)#switchport trunk native vlan 1
S2(config-if-range)#^Z
Tabel VLAN :
S2#sh vlan

VLAN  Name                             Status    Ports
----  -------------------------------- ---------   -------------------------------
1    default                           active    Fa0/5, Fa0/6, Fa0/7,  Fa0/8
 Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,  Fa0/20
 Fa0/21, Fa0/22, Fa0/23,   Fa0/24
2    TI                               active
3    SI                                active
4    SK                                active
5    TKJ                              active
6     INHERENT                         active
1002 fddi-default                      active
1003 token-ring-default                active
1004 fddinet-default                  active
1005  trnet-default                    active   

VLAN Type  SAID        MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1  Trans2
---- -----  ---------- ----- ------ ------ -------- ---- -------- ------  ------
1     enet  100001     1500  -      -      -        -    -        0      0
2     enet  100002     1500  -      -      -        -    -        0      0
Terlihat bahwa, VLAN yang dibuat di S1, akan tereplikasi ke S2.
Berikutnya, pembagian VLAN pada S2 :
S2>
S2>en
S2#conf  t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#interface  fa0/5
S2(config-if)#switchport mode access
S2(config-if)#switchport  access vlan 2
S2(config-if)#exit
S2(config)#interface fa0/6
S2(config-if)#switchport  mode access
S2(config-if)#switchport access vlan 3
S2(config-if)#exit
S2(config)#interface  fa0/7
S2(config-if)#switchport mode access
S2(config-if)#switchport  access vlan 4
S2(config-if)#exit
S2(config)#interface fa0/8
S2(config-if)#switchport  mode access
S2(config-if)#switchport access vlan 5
S2(config-if)#exit
S2(config)#^Z
Tabel VLAN pada S2 :
S2#sh vlan

VLAN Name                             Status    Ports
----  -------------------------------- ---------   -------------------------------
1    default                          active    Fa0/9, Fa0/10, Fa0/11,  Fa0/12
 Fa0/13, Fa0/14, Fa0/15,  Fa0/16
 Fa0/17, Fa0/18, Fa0/19,  Fa0/20
 Fa0/21, Fa0/22, Fa0/23,   Fa0/24
2    TI                               active    Fa0/5
3    SI                               active    Fa0/6
4    SK                               active    Fa0/7
5    TKJ                              active    Fa0/8
6    INHERENT                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active   

VLAN Type   SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1  Trans2
----  ----- ---------- ----- ------ ------ -------- ---- -------- ------   ------
1    enet  100001     1500  -      -      -        -    -         0      0
2    enet  100002     1500  -      -      -        -    -         0      0
3    enet  100003     1500  -      -      -        -    -         0      0
4    enet  100004     1500  -      -      -        -    -         0      0
5    enet  100005     1500  -      -      -        -    -         0      0
6    enet  100006     1500  -      -      -        -    -         0      0
1002 enet  101002     1500  -      -      -        -    -         0      0
1003 enet  101003     1500  -      -      -        -    -         0      0
1004 enet  101004     1500  -      -      -        -    -         0      0
1005 enet  101005     1500  -      -      -        -    -         0      0
Konfigurasi pada switch S3 yang bertindak sebagai client:
Untuk konfigurasi pada switch ini, lakukan perlakuan yang sama dengan switch S2.
Pengujian akses antar VLAN:
Untuk memastikan VLAN yang telah kita buat, berhasil atau tidak, ada baiknya kita melakukan perintah ping dari PC yang yang mempunya VLAN yang sama. Tetapi sebelumnya, mari kita set IP dan Subnet mask pada PC berdasrakan VLAN-nya.
Note : Untuk mampermudah, tidak perlu men-set getway terlebih dahulu (getway dipasang setelah konfigurasi pada router).
Daftar IP pada PC (Sesuai keingian Anda) :
Untuk VLAN 2, saya menggunakan IP yang dimulai dari 192.168.2.11 dengan subnet mask 255.255.255.0
Untuk VLAN 3, saya menggunakan IP yang dimulai dari 192.168.3.11 dengan subnet mask 255.255.255.0
Untuk VLAN 4, saya menggunakan IP yang dimulai dari 192.168.4.11 dengan subnet mask 255.255.255.0
Untuk VLAN 5, saya menggunakan IP yang dimulai dari 192.168.5.11 dengan subnet mask 255.255.255.0
Untuk VLAN 6, saya menggunakan IP yang dimulai dari 192.168.6.11 dengan subnet mask 255.255.255.0
Bila berhasil, kita bisa mengakses antar VLAN sesuai IP masing-masing. Dan pastikan Anda belum bisa mengakes IP yang berbeda VLAN. Karena untuk melakulkan hal tersebut diperlukan sebuah router agar dapat berhubungan antar VLAN.
Penambahan sebuah router (R1) pada S1:
Mengaktifkan dan memberi IP pada interface fa0/0 di R1:
Router>en
Router#conf t
Enter  configuration commands, one per line.  End with CNTL/Z
Router(config)#hostname  R1
R1(config)#interface fa0/0
R1(config-if)#ip address  192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

%LINK-5-CHANGED:  Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN:  Line protocol on Interface FastEthernet0/0, changed  state to up
R1(config-if)#
Konfigurasi di R1 agar antar VLAN dapat saling berhubungan :
R1#conf t
Enter configuration  commands, one per line.  End with CNTL/Z.
R1(config)#interface  fa0/0.2

%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed  state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface  FastEthernet0/0.2,  changed state to upR1(config-subif)#encapsulation  dot1Q 2
R1(config-subif)#ip address 192.168.2.10 255.255.255.0
R1(config-subif)#exit

R1(config)#interface  fa0/0.3

%LINK-5-CHANGED: Interface FastEthernet0/0.3, changed  state to up
R1(config-subif)#encapsulation dot1Q 3
R1(config-subif)#ip  address 192.168.3.10 255.255.255.0
R1(config-subif)#exit
R1(config)#interface  fa0/0.4

%LINK-5-CHANGED: Interface FastEthernet0/0.4, changed  state to up
R1(config-subif)#encapsulation dot1Q 4
R1(config-subif)#ip  address 192.168.4.10 255.255.255.0
R1(config-subif)#exit
R1(config)#interface  fa0/0.5

%LINK-5-CHANGED: Interface FastEthernet0/0.5, changed  state to up
R1(config-subif)#encapsulation dot1Q 5
R1(config-subif)#ip  address 192.168.5.10 255.255.255.0
R1(config-subif)#exit
R1(config)#interface  fa0/0.6

%LINK-5-CHANGED: Interface FastEthernet0/0.6, changed  state to up
R1(config-subif)#encapsulation dot1Q 6
R1(config-subif)#ip  address 192.168.6.10 255.255.255.0
R1(config-subif)#
Mengaktifkan dan memberi IP pada interface fa0/1 di R1:
R1#conf t
Enter configuration  commands, one per line.  End with CNTL/Z.
R1(config)#interface  fa0/0.6
R1(config-subif)#interface fa0/1
R1(config-if)#ip address  192.168.10.1 255.255.255.0
R1(config-if)#no sh
Men-set interface yang berhubungan dengan R1 pada switch S1 sebagai member dari VLAN 5 :
S1#
S1#conf  t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#interface  fa0/24
S1(config-if)#switchport mode access
S1(config-if)#switchport  access vlan 5
S1(config-if)#^Z
Konfigurasi selesai, sekarang Anda dapat melakukan akses antar PC yang ber beda VLAN. Selanjutnya, terserah kita mengembangkan topologi tersebut. Boleh diberi Access point dan sebaginya.

sumurnya dari : https://ayyusriwahyuni.wordpress.com/2010/10/15/stp/

Jumat, 01 April 2016

Interkoneksi Jaringan dengan GRE Tunnel

 

Artikel

Interkoneksi Jaringan dengan GRE Tunnel

Kategori: Fitur & Penggunaan


GRE (Generic Routing Encapsulation) adalah sebuah tunnelling protocol yang sebenarnya dikembangkan oleh Cisco System. Dengan menggunakan protokol ini kita dapat melakukan enkapsulasi berbagai protokol yang dibuat untuk kebutuhan link virtual point-to point.
Selain GRE Tunnel pada MikroTik juga memiliki tunnelling protocol yang lain seperti EoIP dan IPIP yang mana pembahasannya telah lalu. Baik jenis GRE, EoIP, IPIP yang semua pada dasarnya dikembangkan sebagai 'stateless tunnel'. Dimana ketika terdapat link tunnel yang down, maka semua trafik yang melewatinya akan terkena drop/blackhole. Nah, untuk mengatasi hal ini di  RouterOS ditambahakan sebuah fitur 'keepalive' pada GRE Tunnel.
Dengan GRE Tunnel ini akan ditambahakn sebanyak 24 byte di packet header (4-byte gre header + 20-byte IP header).
Studi Kasus
Kali ini kita akan mencoba bagaimana cara melakukan konfigurasi sederahana (Simple Practice) dalam penggunaan GRE Tunnel ini. Berikut ini ada contoh topologi dimana antar jaringan lokal akan saling koneksi via Internet dengan memanfaat GRE Tunnel sebagai jalurnya.
 
Sebagai contoh diatas, kita analogikan terdapat 2 network di tempat yang berjauhan. Diasumsikan untuk membangun infrastruktur sendiri terlalu sulit karena jarak yang terpaut begitu jauh. Maka solusi yang lebih mudah kita akan memanfaatkan jaringan internet dengan memanfaatkan GRE Tunnel.
Konfigurasi GRE Tunnel
Langkah pertama kita akan membuat GRE Tunnel. Untuk Router sisi A konfigurasinya adalah sebagai berikut. Masuk ke menu Interfaces -> GRE Tunnel -> klik Add [+].
Pada parameter 'Local Address', kita isikan dengan IP Public dari Router sisi A dan parameter 'Remote Address' kita isikan dengan IP Public dari Router sisi B. Kemudian kita juga bisa melakukan konfigurasi pada parameter 'Keepalive'. Pada parameter ini seperti yang telah sedikit disinggung diatas tadi bahwa ketika link dari tunnel ini putus maka router akan menjaga interface tunnel tetap dalam keadaan running atau dalam kata lain flag (R) pada interface tersebut tetap ada selama nilai interval yang ditentukan. Secara default nilai dari parameter 'Keepalive' ini adalah 10s (Time Interval), 10 retries (Pengulangan).
Selanjutnya konfigurasi pada Router sisi B juga sama, namun untuk parameter 'Local Address' dan 'Remote Address' adalah kebalikan dari Router sisi A. Jadi untuk 'Local Address' diisi dengan IP Public dari Router sisi B dan 'Remote Address' diisi dengan IP Public dari Router sisi A.
Apabila berhasil maka akan muncul sebuah interface GRE Tunnel pada menu Interfaces sebagai berikut.
Router site A
Router site B
Selanjutnya kita akan memberi masing-masing interface GRE Tunnel dengan IP address PTP. Hal ini berfungsi untuk melakukan routing antar jaringan lokal di masing-masing sisi Router. Seperti contoh topologi diatas kita akan memberi IP Address 10.0.0.1/32 pada GRE-siteA dan IP Address 10.0.0.2/32 pada GRE-siteB.
Setting IP Address pada GRE Tunnel Router A
Setting IP Address pada GRE Tunnel Router B
Karena kita menggunkan IP Address Point-To-Point (IP address dengan prefix /32) maka untuk pengisian network adalah IP Address dari router lawannya. Misal, seperti contoh diatas untuk interface GRE Tunnel router A maka network diisi dengan IP Address dari GRE Tunnel router B. Dan begitu juga konfigurasi untuk sebaliknya.
Konfigurasi Routing
Setelah kita melakukan konfigurasi dari GRE Tunnel, kita akan melakukan routing di masing-masing router agar jaringan lokal bisa saling komunikasi. Seperti biasa kita masuk di menu IP -> Routes -> klik Add [+].
Untuk konfigurasi routing di Router sisi A adalah sebagai berikut.
Dan konfigurasi routing di Router sisi B adalah sebagai berikut.
Nah, sampai dengan langkah ini jaringan lokal antara kedua sisi bisa saling komunikasi secara layer 3 melalui GRE Tunnel.

Jumat, 11 Maret 2016

How To Create a Read Only User in Cisco IOS

Sometimes you will have vendors or junior network administrators needing access to your network equipment. Giving them the keys to the kingdom is not the best decision. Additionally, you’ll need to change the password after the vendor is finished. Or you forget to remove that vendor’s full access account from your router. A safer method is to create a read only account. This is done using privilege levels built into Cisco IOS.
With this method you are using the local database of the router/switch to create a read only user account. The ideal way to grant permissions is to use TACACS+ but that is another discussion.

Create your user accounts

Cisco uses privilege levels to determine what a user account will have access to on the device. There are 16 privilege levels but the system will have two already configured. The rest of the levels are for you to modify. Privilege level 15 is the highest level and is similar to a root user. Privilege level 1 is the lowest of the levels and basically can’t do anything.
Make sure you have an account with full permissions to the device. Then configure a new user for your read only account. I will use privilege level 3 for the read only account.
R1(config)#username admin privilege 15 secret Secret01
R1(config)#username readonly privilege 3 secret ReadOnly03
Of course, use much stronger passwords than the ones I have used above. This is just for lab purposes.

Enable Password Checking

Next, I will apply enable password checking on the vty lines. When a user tries to SSH into my router, they will be prompted for a username and password. Those credentials will be looked up on the local database and if there’s a match, the user is allowed into the router.
R1(config)#line vty 0 15
R1(config-line)#login local

Verify Login

With login local configured for my vty lines, I will attempt to ssh into R1 from R2 using my readonly account.
R2#ssh -l readonly 192.168.1.1
Password:
R1#conf t
      ^
% Invalid input detected at '^' marker.
I am able to ssh into R1 but because I have assigned a privilege level 3 to the account, it can’t really perform any changes or even view the running config file. What we will now configure are commands privilege level 3 users can issue on the CLI. Because this is going to be a read only account, I want to give the user privileges to just see the running config file.

Configure Privilege Level 3 Commands


To assign read only to the running config file we enter global configuration mode and issue the following privilege commands:
R1(config)#privilege exec all level 3 show running-config
R1(config)#end
R1#wr

Verify Read Only

Now we log in again into R1. The command that we will need to run to view the running-config is show running-config view full. If you test any other commands, you will notice the CLI will say it is an invalid input.
R2#ssh -l readonly 192.168.1.1
Password:
R1#
R1#sh running-config view full
Building configuration...
Current configuration : 1428 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
username admin privilege 15 secret 5 $1$76xB$ohfJo9PV9FvooU/mc6Z1N1
username readonly privilege 3 secret 5 $1$jInF$3GGRHULVH3Wuo1wOqpTvs1
!
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface GigabitEthernet2/0
 ip address 192.168.1.1 255.255.255.0
 negotiation auto
!
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
 shutdown
!
privilege exec all level 3 show running-config
privilege exec level 3 show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login local
line vty 5 15
 login local
!
!
end

Rabu, 24 Februari 2016

HowTo : Enable/Disable Interface on CISCO - Shutdown Command



Simple examples of brining up and down the interfaces on CISCO devices with shutdown and no shutdown commands.

Enable an Interface on a CISCO Device

Type the following commands to enable an interface on a CISCO switch or router :


# enable
# configure terminal
(config)# interface FastEthernet 0/1
(config-subif)# no shutdown
(config-subif)# end
# write
To display a status of an interface, use the 'show interfaces status' command :
# show interfaces FastEthernet 0/1 status
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 15 full 100 10/100BaseTX

Disable an Interface on a CISCO Device

Type the following commands to disable an interface on a CISCO switch or router :
# enable
# configure terminal
(config)# interface FastEthernet 0/1
(config-subif)# shutdown
(config-subif)# end
# write
To display a status of an interface, use the 'show interfaces status' command :
# show interfaces FastEthernet 0/1 status
Port Name Status Vlan Duplex Speed Type
Fa0/1 disabled 15 full 100 10/100BaseTX

Senin, 22 Februari 2016

Grammar Bahasa Inggris Nggak Harus Jadi Momok Lagi. Asal Kamu Tahu 11 Trik Ini!

Hipwee.com – Bahasa Inggris kini sudah menjadi konsumsi sehari-hari. Sejak di bangkusekolah, menguasai bahasa yang disebut-sebut jadi bahasa internasional ini adalah sebuah keharusan. Bahkan, sudah jadi mata pelajaran yang diujikan di Ujian Nasional. Bener nggak?Bahkan, walaupun sudah tidak di bangku sekolah, baca-baca berita dari portal dengan sumber bahasa Inggris sudah jadi kebutuhan. Untuk tetap update, kamu pun juga harus menguasai bahasa ini.
Sudah bukan rahasia lagi kalau grammaratau tata bahasasudah menjadi momok turun-temurun saat mempelajari bahasa Inggris. Tenang, kamu nggak perlu merasa takut dan kesulitan lagi. Hipwee sudah merangkum 11 tips asik dan mujarab dalam mempelajari grammar.

1. 12 Tenses nggak akan bikin kamu kebingungan lagi. Timeline ini akan memudahkan kamu untuk pakai tenses yang mana.

Timeline sakti mandraguna
Timeline sakti mandraguna via www.englishlessonsbrighton.co.uk
Tenses adalah momok paling menakutkan yang sering bikin putus asa waktu mempelajarinya. Karena bahasa Inggris itu akan selalu menjadikan waktu sebagai pembeda dalam setiap konteksnya. Beda dengan bahasa Indonesia
yang nggak bikin pusing. Contohnya saja kalimat ini….
Saya makan.
Dalam bahasa Indonesia, kegiatan makanmu ini tidak memiliki patokan waktu. Sedangkan bahasa inggrisnya, kamu harus menyesuaikan dulu dengan waktu.
Kapan makannya? Kemarin? Tadi? Atau besok? Bentuk verb-nya juga akan ikut berubah.
Nah, kamu tidak perlu bingung lagi. Semua masalah untuk menghafalkan tenses akan terselesaikan dengan menghafalkan dari timeline ini. Jadi lebih mudah, kan?

2. Menghafalkan verb bentuk 1-2-3, baikregular dan irregular bisa kamu siasati dengan trik asik di kartu-kartu ini.

Coba mainin kartu ini....
Coba mainin kartu ini…. via www.amazon.ca
Untuk melancarkan usahamu menguasai tenses, kamu nggak boleh berpuas diri dulu. Ada satu hal lagi yang harus kamu selesaikan, yaitu menghapalkan berbagai macam tenses.Verb tenses terbagi jadi 2 bentuk, beraturan (regular) dan tidak beraturan (irregular). Dari verbs-nya sendiri, terbagi jadi 3 bagian, yaitu verb bentuk1, 2, dan 3 yang punya bentuk yang berbeda-beda, kan. Dan yang perlu kamu tahu, verb itu banyak banget jumlahnya.
Untuk membantumu menghapal verb 1,2,3, alangkah baiknya kamu buat dengan aktifitas yang menyenangkan. Coba kamu hapalkan 5 buahverb dalam sehari yang sudah kamu tulis dalambentuk kartu-kartu. Kalau sehari kamu bisa hapal 5 kata kerja dan ketiga bentuk verb-nya, tiap minggu kamu bisa hapal 35 verbs. Satu bulan, kamu sudah hapal berapa banyak bentuk verbs?Memudahkan sekaligus menguntungkan kamu, kan?

3. Penggunaan at, in, on sudah bukan masalah lagi dengan diagrampreposition ini.

Diagram sakti
Diagram sakti via happyhuhoho.wordpress.com
Preposition adalah kata yang dipakai untuk melengkapi keterangan waktu dan tempat. Terdiri dari at, in, dan on. Kadang, banyak orang dibuat bingung dengan penggunaan ketiga kata ini karena pada dasarnya memiliki arti yang hampir sama, yaitu di dan pada. Nah, untuk membedakan cara pemakaiannya, kamu akan dipermudah dengan diagram segitiga di atas. Bingung udah nggak akan mengusikmu lagi kan, guys.

4. Mau pakai relative pronouns sudah tidak perlu bingung. Tinggal bedakan posisi objek dalam kalimatnya.

Kurang lebih seperti ini...
Kurang lebih seperti ini… via www.crafting-connections.blogspot.co.id
Untuk menghubungkan kalimat, dibutuhkan kata ganti untuk menambah keterangan. Di bahasa Inggris, ada 5 macam relative pronoun, yaituwho, whom, what, which, dan that. Di tiap pronoun, punya fungsi masing-masing tergantung dari subyek yang diterangkan. Coba kamu hapalkan satu satu. Kamu tinggal pakai sesuai dengan posisinya di dalam kalimat.
who = menggantikan keterangan orangsebagai subyek.
whom = menggantikan keterangan orang sebagai obyek.
which =menggantikan keterangan subyek dalam bentuk benda.
whose =menggantikan keterangan milik.
that = menggantikan keterangan subyek dalam segala bentuk.

5. Nggak usah rebutan punyaku atau punya orang lain. Possesive pronouns gampang kok buat dihapalin.

Mudah kan
Mudah kan via www.showme.com
Buat menentukan kepemilikan dari sesuatu, kamu nggak perlu susah-susah untuk menghapalkan. Kamu bisa cari di googletabel possesive pronouns. Dijamin, kamu akan dimanjakan dengan berbagai macam tabel yang lengkap. Kamu bisa hapalkan dengan mudah kan jadinya. Mungkin kamu bisa sedikit berkreasi dengan nyanyian. Jadi lebih gampang diingat, kan?

6. Bikin kalimat pasif itu semudah menjentikkan jari aja kok sebenernya. Tinggal ubah sedikit to be dan verb-nya.

Ini contohnya...
Ini contohnya… via www.showme.com
Kalimat pasif itu nggak susah kok guys sebenernya. Aturan mainnya adalah dengan memosisikan obyek sebagai subyek kalimat. Nah, kalau di bahasa Inggris, kamu tinggal ubah to be dan verb-nya dalam bentuk yang berbeda.

7. Pakai determiners sudah nggak perlu khawatir salah. A, an, danthe bisa ditentukan dari melihat subyeknya aja.

Like this...
Like this… via ctl.yale.edu
Dalam bahasa inggris, determiners itu penting. Untuk menentukan determiners yang harus dipakai di awal kalimat,dapat dilihat darisubyeknya kok. Kalau subyeknya lebih dari 1, kamu tidak perlu pakai determiners apa-apa. Kalau subyeknya berawalan huruf konsonan, kamu bisa pakai a. Sedangkan jika subyeknya adalah diawali atau dilafalkan seperti huruf vokal, kamu wajib pakai an. Gampang, kan?

8. Menentukan anything, something, dan nothing itu mudah. Asal tahu aturan mainnya aja.

Anything nothing something
Anything nothing something via remijones.deviantart.com
Kata-kata ini adalah yang sering banget dipakai dalam berbagai kalimat dalam bahasa Inggris.Namun sering juga ada yang salah dalam menggunakannya. Ada perbedaan dalam penggunaan masing-masing kata. Something digunakan untuk kalimat positif. Kalau anything sih biasanya digunakan untuk kalimat tanya dan kalimat negatif. Pun demikian dengannothing. Nothing digunakan untuk kalimat negatif dan tanya. Bedanya adalah dari segi makna. Nothing berarti “tidak” sedangkan anythingbermakna “apa saja”.

9. Bikin kalimat majemuk pake who, which, where, dan semacamnya nggak perlu mikir lama lagi sekarang dengan memahami relativeclause.

Gampang kok sebenernya
Gampang kok sebenernya via www.cepagernika.com
Untuk menyusun sebuah kalimat, paling tidak dibutuhkan sebuah subyek, predikat, dan obyek. Kalau kamu ingin mengasah kemampuanmu untuk membuat kalimat majemuk, dibutuhkan kata hubung untuk memperjelas kalimatberikutnya.Dalam bahasa Inggris, ada who, which, where, yang punya fungsi sendiri- sendiri.Nggak berbeda jauh dari relative pronouns sebenernya, inibisa digunakan dalam kalimat yang lebih kompleks aja.

10. Mau bikin kata-kata manis pake comparative dan superlative adjective sudah bukan masalah besar.

Contoh tabelnya~
Contoh tabelnya~ via www.tes.com
Dalam membuat perbandingan, kamu juga harus berusaha lagi untuk mempelajarinya. Yaitu dengan memahami materi comparative dan superlative adjective. Caranya membedakannya mudah banget, nih.
Dalam membandingkan sesuatu yang memiliki sifat yang “lebih” dari yang lain, kamu bisa memakai rumus dari comparative adjective ini. Untuk kata sifat yang memiliki 2 suku kata, kamu cukup tambahkan -er di belakangnya. Jika kata sifatnya memiliki lebih dari 2 suku kata, kamu harus tambahkan more di depan kata sifat tersebut.
Sedangkan di superlative adjective, kamuakanmenjadikan sesuatu sebagai yang “paling” dalam sebuah kumpulan.Cara mainnya hampir sama. JikaUntuk kata sifat yang memiliki 2 suku kata, kamu cukup tambahkan -estdi belakangnya. Jika kata sifatnya memiliki lebih dari 2 suku kata, kamu harus tambahkan mostdi depan kata sifat tersebut.

11. Untuk hasil yang maksimal, jangan bosan untuk mengerjakan latihan soalnyaya. Karena practice makes perfect



Setelah mempelajari berbagai macam materi yang sudah mudah, jangan segan buat melatih pemahaman kamu, ya. Dengan terus berlatih, apa yang kamu dapat nggak akan mudah lupa dan akan terus kamu ingat. Nah, Hipwee jugasudah merangkum beberapa situs yang akan mempermudah belajar bahasa Inggrismu di artikel Meski Tanpa Ikut Kursus, 8 Situs Ini yang Bakal Membuat Skill-mu Bertambah Terus!. Selain itu, kamu pun tidak boleh bosan untuk terus mencoba cara belajar yang menyenangkan, seperti menonton film tanpa bantuan subtitle, mendengar dan memaknai lagu-laguyang berbahasa Inggris, dan berkomunikasi langsung dengan orang native-nya.
Dari 11 tips mujarab di atas, mana nih yang udah nggak sabar untuk kamu praktekkan, guys? Semakin tekun kamu belajar, semakin mudah pula kamu menguasai grammar.Nggak usah takut salah lagi deh.

Jumat, 12 Februari 2016

Konfigurasi VLAN Cisco Switch




vlan, konfigurasi vlan, vlan switch, lab packet tracer vlan
Lab Konfigurasi VLAN
RoadToCCNA –  Bahasan ini adalah lanjutan dari bahasan sebelumnya tentang konfigurasi Cisco Switch Tingkat Dasar. VLAN atau Virtual Local Area Network ini merupakan salah satu fitur terpenting dalam sebuah switch manageable. Vitur VLAN ini mengacu pada standar 802.1Q yang bertujuan utama mengalokasikan atau mensegmentasikan pertukaran data lebih efisien berdasarkan penggunaan port switch, sehingga suatu jaringan menjadi lebih kecil untuk mengurangi beban kerja switch tersebut.
Nah, pada bahasan kali ini, kita akan menggunakan Packet Tracer v5.3 untuk mengkonfigurasi VLAN dengan menggunakan sebuah router untuk mengsub-interfacekan VLAN it sendiri. Nah, lho apaan tuh sub-interface? Maksudnya begini kawan, jika diimplementasikan dalam dunia nyata, harga sebuah interface pada router cukup mahal, oleh karena itu fungsi dari subinterface tersebut adalah membagi sebuah interface menjadi beberapa interface sub hanya dengan satu buah interface router saja.
Yuk kita langsung bereksplorasi kawan!
Saat ini kita akan membangun VLAN pada sebuah gedung dengan menggunakan IP private sebagai percobaan. Penjelasannya sebagai berikut:
VLAN 10 : 192.168.1.0/24 Hostname Switch_lantai1
VLAN 20 : 192.168.2.0/24 Hostname Switch_lantai2
VLAN 30 : 192.168.3.0/24 Hostname Switch_lantai3
VLAN 40 : 192.168.4.0/24 Hostname Switch_lantai4
VLAN 50 : 192.168.5.0/24 Hostname Switch_lantai5
Konfigurasi Switch 0
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Switch_pusat
Switch_pusat(config)#banner motd &
Enter TEXT message. End with the character ‘&’.
**********************************************************************
———————-HANYA UNTUK AKSES TERTENTU!—————————–
LAKUKAN PENYIMPANAN DATA SEBELUM DAN SESUDAH KONFIGURASI
**********************************************************************
&
Switch_pusat(config)#enable password cisco
Switch_pusat(config)#line console 0
Switch_pusat(config-line)#password console
Switch_pusat(config-line)#exec-timeout 0 0
Switch_pusat(config-line)#login
Switch_pusat(config-line)#logging synchronous
Switch_pusat(config-line)#exit
Switch_pusat(config)#line vty 0 4
Switch_pusat(config-line)#password telnet
Switch_pusat(config-line)#exec-timeout 0 0
Switch_pusat(config-line)#login
Switch_pusat(config-line)#logging synchronous
Switch_pusat(config-line)#exit
//Menamakan VLAN yang akan digunakan
Switch_pusat(config)#vlan 10
Switch_pusat(config-vlan)#name Switch_lantai1
Switch_pusat(config-vlan)#exit
Switch_pusat(config)#vlan 20
Switch_pusat(config-vlan)#name Switch_lantai2
Switch_pusat(config-vlan)#exit
Switch_pusat(config)#vlan 30
Switch_pusat(config-vlan)#name Switch_lantai3
Switch_pusat(config-vlan)#exit
Switch_pusat(config)#vlan 40
Switch_pusat(config-vlan)#name Switch_lantai4
Switch_pusat(config-vlan)#exit
Switch_pusat(config)#vlan 50
Switch_pusat(config-vlan)#name Switch_lantai5
Switch_pusat(config-vlan)#exit
//Mengatur switchport mode trunk dan access
Switch_pusat(config)#interface fastEthernet0/24
Switch_pusat(config-if)#switchport mode trunk
Switch_pusat(config-if)#exit
Switch_pusat(config)#interface fastEthernet0/1
Switch_pusat(config-if)#switchport mode access
Switch_pusat(config-if)#switchport access vlan 10
Switch_pusat(config-if)#exit
Switch_pusat(config)#interface fastEthernet0/2
Switch_pusat(config-if)#switchport mode access
Switch_pusat(config-if)#switchport access vlan 20
Switch_pusat(config-if)#exit
Switch_pusat(config)#interface fastEthernet0/3
Switch_pusat(config-if)#switchport mode access
Switch_pusat(config-if)#switchport access vlan 30
Switch_pusat(config-if)#exit
Switch_pusat(config)#interface fastEthernet0/4
Switch_pusat(config-if)#switchport mode access
Switch_pusat(config-if)#switchport access vlan 40
Switch_pusat(config-if)#exit
Switch_pusat(config)#interface fastEthernet0/5
Switch_pusat(config-if)#switchport mode access
Switch_pusat(config-if)#switchport access vlan 50
Switch_pusat(config-if)#exit
Switch_pusat(config)#end
Switch_pusat#
%SYS-5-CONFIG_I: Configured from console by console
Switch_pusat#write memory
Building configuration…
[OK]

Konfigurasi Router 0
Router>enable
Router#hostname Router_pusat
Router_pusat#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

//Memberikan alokasi IP address untuk masing-masing VLAN
Router_pusat(config)#interface fastEthernet0/0
Router_pusat(config-if)#no shutdown
Router_pusat(config-if)#exit

Router_pusat(config)#interface fastEthernet0/0.10
Router_pusat(config-subif)#encapsulation dot1Q 10
Router_pusat(config-subif)#ip address 192.168.1.1 255.255.255.0
Router_pusat(config-subif)#exit
Router_pusat(config)#int f0/0.20
Router_pusat(config-subif)#enc dot 20
Router_pusat(config-subif)#ip add 192.168.2.1 255.255.255.0
Router_pusat(config-subif)#ex
Router_pusat(config)#int f0/0.30
Router_pusat(config-subif)#enc dot 30
Router_pusat(config-subif)#ip add 192.168.3.1 255.255.255.0
Router_pusat(config-subif)#ex
Router_pusat(config)#int f0/0.40
Router_pusat(config-subif)#enc dot 40
Router_pusat(config-subif)#ip add 192.168.4.1 255.255.255.0
Router_pusat(config-subif)#ex
Router_pusat(config)#int f0/0.50
Router_pusat(config-subif)#ip add 192.168.5.1 255.255.255.0
Router_pusat(config-subif)#ex
Router_pusat(config)#wr mem
Building configuration…
[OK]

Ok, terakhir kita bisa melakukan pengetesan dengan Ping dari PC satu ke PC lainnya.
Jika ada failed, bisa jadi karena settingan IP gateway pc yang tidak sesuai (atau di troubleshoot dulu, jika ada masalah bisa kita diskusikan kawan ;)

Salam,

Selasa, 26 Januari 2016

Cara Mencegah Client Mengganti DNS secara Manual

Bagaimana cara mencegah client mengganti DNS manual misal ke 8.8.8.8? Pertanyaan ini ada pada artikel sebelumnya yakni : Cara Mudah Memblokir Situs-situs Dewasa dengan DNS di Mikrotik. Nah pada artikel kali ini saya akan coba menjawab nya dan memberikan solusi mencegah client mengganti DNS secara manual menggunakan Mikrotik.
Sebenarnya lebih tepat kalau kita sebut "Memaksa" Client menggunakan DNS Mikrotik. Karena siapapun bisa saja merubah setingan DNS di PC nya masing-masing. Nah, hal yang akan kita lakukan ini adalah memaksa client tersebut untuk menggunakan DNS kita walaupun DNS di PC nya sudah dirubah misal ke 8.8.8.8. Gimana caranya? Simak tutorial berikut :
Tutorial Cara Mencegah Client Mengganti DNS secara Manual :
1. Login ke Mikrotik via Winbox 
2. Masuk ke menu IP --> Firewall --> NAT --> Add --> 
- Pada tab General : 
==> Chain : dstnat
==> Protocol : 17 (udp)
==> Dst. Port : 53
- Pada tab Action :
==> Action : Redirect
==> To Ports : 53
3. Coba anda cek di PC, ganti DNS ke manual misal 8.8.8.8 dan akses situs yang harusnya diblokir.
4. Jika masih bisa, coba flush dulu DNS Cache nya di Mikrotik dan PC nya
Oke, selamat mencoba tutorial Cara Mencegah Client Mengganti DNS secara Manual ini ya. Semoga sukses :)

Kamis, 21 Januari 2016

Interkoneksi Jaringan dengan Tunnel

Pada saat sebuah peruahaan memiliki kantor cabang, biasanya perusahaan menginginkan antara kantor pusat dengan kantor cabang bisa saling interkoneksi. Dapat melakukan file sharing, VOIP, dan kebutuhan pertukaran informasi dalam jaringan lainnya. Masalah muncul apabila ternyata kantor pusat dengan kantor cabang berbeda kota. Akan butuh biaya mahal jika harus membangun infrastruktur kabel/wireless/fiber-optic yang digunakan untuk menghubungkan antara kantor pusat dengan kantor cabang. MikroTik memberikan solusi yang cukup ekonomis dan reliable untuk masalah ini, salah satunya dengan Tunnel.
Untuk membangun tunnel, kedua kantor baik kantor cabang maupun kantor pusat harus terkoneksi ke internet dan memiliki IP public static. Tunneling merupakan salah satu cara untuk membangun sebuah jalur  antar mikrotik router di atas sebuah koneksi TCP/IP. Jika digambarkan dalam bentuk topologi, akan terlihat seperti berikut :
 
Nantinya, jaringan lokal dibawah router di kantor cabang dan router di kantor pusat akan bisa saling bertukar informasi dan bertukar file. Kita coba jabarkan topologi secara teknis agar lebih mudah bagi kita untuk memahami penerapan tunnel ini.
Jika kita perhatikan jaringan lokal di Head Office dan Branch Office memiliki segment network yang sama. Dan nantinya kedua jaringan lokal ini akan dapat saling berkomunikasi dengan memanfaatkan fitur tunneling di MikroTik.
Ethernet over IP (EoIP)
Merupakan protocol pada Mikrotik RouterOS yang berfungsi untuk membangun sebuah Network Tunnel antar MikroTik router di atas sebuah koneksi TCP/IP. EoIP merupakan protokol proprietary MikroTik (support juga di linux tetapi harus di-compile manual). Maka untuk menggunakan fitur ini, router di Head Office dan router di Branch Office harus sama - sama menggunakan router MikroTik. EoIP menggunakan Protocol GRE (RFC1701).
Dari detail topologi yang sudah digambarkan diatas, kita akan coba implementasikan dengan EoIP. Maka kita bisa lakukan langkah konfigurasi sebagai berikut. Pertama, tambahkan interface EoIP di menu "Interfaces". Klik tombol + (add), kemudian pilih EoIP. Langkah ini dilakukan di kedua router, baik router di Head Office maupun router di Branch Office
Akan muncul properties interface baru yang perlu kita setting, yang paling penting adalah parameter "Remote Address" dan "Tunnel ID". Pada saat setting router MikroTik disisi Head Office, isi parameter Remote Address dengan IP Public yang dimiliki oleh router yang ada di Branch Office. Lakukan hal yang sama ketika setting router disisi Branch Office, bisa dianalogikan seperti bertukar informsi IP Public. Kemudian pada parameter Tunnel ID, pastikan memiliki nilai yang sama antara Tunnel ID router Head Office dengan router Branch Office.
Jika EoIP sudah berjalan dan muncul flag "R", selanjutnya kita buat bridge yang nanti akan menjembatani transmisi data dari jaringan LAN yang akan melewati EoIP. Masuk ke menu Bridge, kemudian klik tombol + (add). Isi nama bridge sesuai keinginan.
Selanjutnya, tambahkan interface EoIP dan interface ethernet yag terkoneksi ke jaringan lokal LAN ke dalam Port Bridge. Jadi ada dua interface yang menjadi port bridge.
Jika sudah selesai, coba ping antar host dari jaringan lokal dibawah router, misal dari host lokal yang berada di Head Office ping ke host yang berada di Branch Office.
IP-in-IP (IPIP)
Salah satu alternatif tunnel selain menggunakan EoIP adalah dengan menggunakan IPIP. Implementasi IPIP di mikrotik berdasarkan RFC2003. Protokol IPIP berkerja dengan mengenkapsulasi paket data dari satu IP ke IP lain untuk membentuk network tunnel. Berbeda dengan EoIP yang hanya bisa digunakan untuk router yang sama - sama MikroTik, IPIP dapat berjalan hampir di semua jenis router selama router tersebut mendukung protokol IPIP. Akan tetapi, IPIP tidak dapat di-bridge sehingga jringan lokal dibahwa router Head Office dan Branch Office harus menggunakan segmen IP addres yang berbeda. Misalkan kita akan membangun tunnel IPIP dengan topologi sebegai berikut :
Hampir sama dengan EoIP, buat interface IPIP di kedua router, router Head Office dan router Branch Office. Masuk ke menu "Interfaces", klik tombol + (add), kemudian pilih IP Tunnel.
Pada parameter "Local Address", isi dengan IP Pubic yang ada di router itu sendiri, dan isi parameter "Remote Address" dengan IP Public router lawan. Misal untuk router Head Office local-address adalah 202.1.2.1 dan remote-address adalah 202.2.3.1. Hal serupa juga dilakukan disisi Branch Office.
Jika IP Tunnel sudah terbentuk, tambahkan IP address pada interface tunnel tersebut. Masuk ke menu "IP Address", kemudian klik tombol + (add). IP address yang ditambahkan di sisi Head Office dan Branch Office harus satu segmen. Pada contoh dibawah ini kita tambahkan IP Address 192.168.2.1/24 disisi Head Office dan IP address 192.168.2.2/24 disisi Branch Office.
 
Sekarang coba lakukan ping antar router dengan menggunakan IP address yang baru saja dipasang tadi. Jika IP Tunnel udah berjalan, maka ping akan berjalan normal dengan menggunakan segmen IP 192.168.2.0/24. Pertanyaannya apakah jaringan lokal di kedua kantor sudah bisa interkoneksi ? dan ternyata belum bisa saling interkoneksi karena berbeda segmen. Kita perlu membuat rule static route agar kedua jaringan bisa saling mengenal walaupun berbeda segmen.
Setelah kita tambahkan rule routing tadi, host yang berada di jaringan lokal Head Office akan bisa saling interkoneksi dengan host yang berada di jaringan lokal Branch Office.

sumber : mikrotik.co.id